Trie树

sdjasj

基本思想

高效地存储和查找字符串集合的数据结构,存储的字母或者数字种类不能太多

存储ABD AC ABE可以表示为

graph TD;
    A-->B;
    A-->C;
    B-->D;
    B-->E;

在单词结尾打标记,如上面的D E C,以便知道树根到当前节点是不是一个单词

模板

Trie字符串统计

维护一个字符串集合,支持两种操作:

  1. I x 向集合中插入一个字符串 x;
  2. Q x 询问一个字符串在集合中出现了多少次。

共有 N个操作,所有输入的字符串总长度不超过 105,字符串仅包含小写英文字母。

输入格式

第一行包含整数 N,表示操作数。

接下来 N 行,每行包含一个操作指令,指令为 I xQ x 中的一种。

输出格式

对于每个询问指令 Q x,都要输出一个整数作为结果,表示 x 在集合中出现的次数。

每个结果占一行。

数据范围

1≤N≤2∗1041≤N≤2∗104

输入样例:

1
2
3
4
5
6
5
I abc
Q abc
Q ab
I ab
Q ab

输出样例:

1
2
3
1
0
1
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>

using namespace std;

const int N = 1e5 + 7;

int trie[N][26], cnt[N], idx;
char ss[N];
char op[2];
int n;



void insert(char s[]) {
int p = 0;
for (int i = 0; s[i]; i++) {
int t = s[i] - 'a';
if (!trie[p][t]) {
trie[p][t] = ++idx;
}
p = trie[p][t];
}
cnt[p]++;
}

int query(char s[]) {
int p = 0;
for (int i = 0; s[i]; i++) {
int t = s[i] - 'a';
if (!trie[p][t]) {
return 0;
}
p = trie[p][t];
}
return cnt[p];
}

int main() {
cin >> n;
while (n--) {
scanf("%s%s", op, ss);
if (op[0] == 'I') {
insert(ss);
} else {
cout << query(ss) << endl;
}
}
return 0;
}

  • 標題: Trie树
  • 作者: sdjasj
  • 撰寫于: 2023-01-23 21:43:12
  • 更新于: 2023-01-23 21:53:01
  • 連結: https://redefine.ohevan.com/2023/01/23/Trie树/
  • 版權宣告: 本作品采用 CC BY-NC-SA 4.0 进行许可。
 留言
此頁目錄
Trie树